$re = '/\b(\w+)\b(?=.*\b\1\b)/';
$str = 'Edit the Expression & Text to see matches. Try to find the Text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);