re = /\b(\w+)\b(?=.*\b\1\b)/
str = 'Edit the Expression & Text to see matches. Try to find the Text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end