package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^:]+): ([^\t\r\n]*)[\t\r\n]*`)
var str = `Name: hlarlg
Hola: gioiaerjg
Phone number: giejoar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}