$re = '/(^[^:]+): ([^\t\r\n]*)[\t\r\n]*/m';
$str = 'Name: hlarlg
Hola: gioiaerjg
Phone number: giejoar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);