import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+(?: \\w+)* +V\\d{1,2}\\.\\d{1,2} +(?:3[01]|[12][0-9]|0[1-9])\\/(?:1[0-2]|0[1-9])\\/(?:20)?[0-9]{2}";
final String string = "hardware -v\n"
+ "...(need to ignore junk here in case there is any)\n"
+ "MyHardware V1.23 01/02/20 (This is the only line I need)\n"
+ "PROCESSOR:xxxxxxxxxx\n"
+ "abc <n> <c> [r] \n"
+ "def <n> <c> [r]\n\n\n"
+ "MyHardware V1.23 01/02/03\n"
+ "MyHardware V12.34 01/02/03\n"
+ "MyHardware V1.23 01/02/2003\n"
+ "MyHardware V12.34 01/02/2003\n\n"
+ "My Hardware V1.23 01/02/20";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}