# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\w+(?: \w+)* +V\d{1,2}\.\d{1,2} +(?:3[01]|[12][0-9]|0[1-9])\/(?:1[0-2]|0[1-9])\/(?:20)?[0-9]{2}"
test_str = ("hardware -v\n"
"...(need to ignore junk here in case there is any)\n"
"MyHardware V1.23 01/02/20 (This is the only line I need)\n"
"PROCESSOR:xxxxxxxxxx\n"
"abc <n> <c> [r] \n"
"def <n> <c> [r]\n\n\n"
"MyHardware V1.23 01/02/03\n"
"MyHardware V12.34 01/02/03\n"
"MyHardware V1.23 01/02/2003\n"
"MyHardware V12.34 01/02/2003\n\n"
"My Hardware V1.23 01/02/20")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.