const regex = new RegExp('(?<=[^/]>)[^>\\P{IsBasicLatin}]*[\\p{IsHiragana}\\p{IsKatakana}\\p{IsCJKUnifiedIdeographs}]+[^>\\P{IsBasicLatin}]*(?=</)', 'gi')
const str = `<tag3>Some text before 日本語 and some text after</tag3><tag>Before text 漢字</tag>.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}