package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.X|..X|X.`)
var str = `1234X5678`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}