$re = '/.X|..X|X./';
$str = '1234X5678';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);