#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bid\b=\[(.+?)\]"
Local $sString = "@client.test.annotations.TestInfo(id=[]) //ignore this time" & @CRLF & _
" @org.testng.annotations.Test(alwaysRun=true,..." & @CRLF & _
"@client.test.annotations.TestInfo(id=[C10137, C12121])" & @CRLF & _
" @org.testng.annotations.Test(alwaysRun=true,..." & @CRLF & _
"@client.test.annotations.TestInfo(id=[C10137])" & @CRLF & _
"@org.testng.annotations.Test(alwaysRun=false, expectedExceptions=[].."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")