$re = '/.+(?=\/thanks$).+/m';
$str = 'www.company.com/orders/thanks
www.company.com/orders/thanks/1sfasd523425';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);