re = /.+(?=\/thanks$).+/m
str = 'www.company.com/orders/thanks
www.company.com/orders/thanks/1sfasd523425'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end