$re = '/<(/?[BIT)(html)(body)(title)(head)]+)>/i';
$str = 'Native object recogition <B>is much better</B> then other types. Or <I>is in italic</I> and not in <B>bold</B> types <b>face</b>.
<!DOCTYPE HTML>
<html>
<head>
<title>Title of the document</title>
</head>
<body>
The content of the document......
</body>
</html>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);