// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<(/?[BIT)(html)(body)(title)(head)]+)>").unwrap();
let string = "Native object recogition <B>is much better</B> then other types. Or <I>is in italic</I> and not in <B>bold</B> types <b>face</b>.
<!DOCTYPE HTML>
<html>
<head>
<title>Title of the document</title>
</head>
<body>
The content of the document......
</body>
</html>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}