package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d+)(?:(?:\-|\.\.)(\d+))?\,?$`)
var str = `1-4
1
1,2,3,4,5..6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}