$re = '/^(\d+)(?:(?:\-|\.\.)(\d+))?\,?$/';
$str = '1-4
1
1,2,3,4,5..6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);