import re
regex = re.compile(r"(?P<destination>\d+\.\d+\.\d+\.\d+)\ +(?P<gateway>\d+\.\d+\.\d+\.\d+)\ +(?P<mask>\d+\.\d+\.\d+\.\d+)\ +\w+\ +\d+\ +\d+\ +\d+\ +(?P<interface>\w+)")
test_str = ("Table de routage IP du noyau\n"
"Destination Passerelle Genmask Indic Metric Ref Use Iface\n"
"0.0.0.0 192.168.100.254 0.0.0.0 UG 100 0 0 enp2s0\n"
"10.8.0.1 10.8.0.109 255.255.255.255 UGH 0 0 0 tun0\n"
"10.8.0.109 0.0.0.0 255.255.255.255 UH 0 0 0 tun0\n"
"192.168.10.0 10.8.0.109 255.255.255.0 UG 0 0 0 tun0\n"
"192.168.100.0 0.0.0.0 255.255.255.0 U 100 0 0 enp2s0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")