import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=where)(.*?)((ORDER BY|GROUP BY|HAVING|LIMIT|OFFSET|$).*)";
final String string = "select \"DIM_1\".\"col1\",\n"
+ "\"DIM_2\".\"col2\" ,\n"
+ "\"DIM_3\".\"col3\" , \n"
+ "\"DIM_4\".\"col4\" , \n"
+ "\"FAT_1\".\"col5\" \n"
+ "from \"FAT_1\",\n"
+ " \"DIM_1\",\n"
+ " \"DIM_2\",\n"
+ " \"DIM_3\",\n"
+ " \"DIM_4\"\n"
+ "where \"DIM_1\".\"col1\" IS NOT NULL \n"
+ "AND \"DIM_2\".\"col2\" LIKE ('SUCCESS')\n"
+ "AND \"DIM_3\".\"col3\" BETWEEN 20161213 AND 20161222\n"
+ "AND \"DIM_4\".\"col4\" > 0\n"
+ "HAVING DIM_1.col1 > 2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}