import re
regex = re.compile(r"(?<=where)(.*?)((ORDER BY|GROUP BY|HAVING|LIMIT|OFFSET|$).*)", flags=re.DOTALL | re.IGNORECASE)
test_str = ("select \"DIM_1\".\"col1\",\n"
"\"DIM_2\".\"col2\" ,\n"
"\"DIM_3\".\"col3\" , \n"
"\"DIM_4\".\"col4\" , \n"
"\"FAT_1\".\"col5\" \n"
"from \"FAT_1\",\n"
" \"DIM_1\",\n"
" \"DIM_2\",\n"
" \"DIM_3\",\n"
" \"DIM_4\"\n"
"where \"DIM_1\".\"col1\" IS NOT NULL \n"
"AND \"DIM_2\".\"col2\" LIKE ('SUCCESS')\n"
"AND \"DIM_3\".\"col3\" BETWEEN 20161213 AND 20161222\n"
"AND \"DIM_4\".\"col4\" > 0\n"
"HAVING DIM_1.col1 > 2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")