const regex = /u0026itag=22\\u0026url=(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('u0026itag=22\\\\u0026url=(.*)', '')
const str = `https://vd21.mycdn.me/?expires=1524707361628\\\\u0026srcIp=202.53.144.67\\\\u0026srcAg=CHROME\\\\u0026type=4\\\\u0026sig=06852bb2eb021f9273c04666ce50a9ec284f31a8\\\\u0026ct=0\\\\u0026urls=217.20.157.207\\\\u0026clientType=0\\\\u0026id=476239628800`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}