$re = '/u0026itag=22\\\\u0026url=(.*)/';
$str = 'https://vd21.mycdn.me/?expires=1524707361628\\\\u0026srcIp=202.53.144.67\\\\u0026srcAg=CHROME\\\\u0026type=4\\\\u0026sig=06852bb2eb021f9273c04666ce50a9ec284f31a8\\\\u0026ct=0\\\\u0026urls=217.20.157.207\\\\u0026clientType=0\\\\u0026id=476239628800';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);