use strict;
my $str = '0101110112011301210122012301310132013301410142014301B
0101B
0101B12B
01011011B
0101B121111B
010110111011B
0101B1210111011B
0520D01D53D
0620E01E53D
0724
0803E23J54B
0903
1006E25J56B
1103B01
1407
1504
1807E30J61B
1904K24R
2003K41M54R
2104K06R
2203H37M68B
72B6P271531
05BRE010941';
my $regex = qr/^([A-Za-z0-9]{2})([0-9]{2})((?:[A-R][0-9]{2}){0,10})((?:[0-9]{4}){0,12})((?:[A-Z])?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}