re = /^([A-Za-z0-9]{2})([0-9]{2})((?:[A-R][0-9]{2}){0,10})((?:[0-9]{4}){0,12})((?:[A-Z])?)$/m
str = '0101110112011301210122012301310132013301410142014301B
0101B
0101B12B
01011011B
0101B121111B
010110111011B
0101B1210111011B
0520D01D53D
0620E01E53D
0724
0803E23J54B
0903
1006E25J56B
1103B01
1407
1504
1807E30J61B
1904K24R
2003K41M54R
2104K06R
2203H37M68B
72B6P271531
05BRE010941'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end