#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^-]+-([^=]+)=.)([^-]*?)\1([^-]*)-[^=]+=\2\3$"
Local $sString = "abc-b=ac" & @CRLF & _
"abcde-cd=abe" & @CRLF & _
"ab-a=b" & @CRLF & _
"abcde-a=bcde" & @CRLF & _
"abcde-cde=ab" & @CRLF & _
"" & @CRLF & _
"abc-a=c" & @CRLF & _
"abcde-bd=ace" & @CRLF & _
"abc-cd=ab" & @CRLF & _
"abcde-a=cde" & @CRLF & _
"abc-abc=" & @CRLF & _
"abc-=abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")