import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^-]+-([^=]+)=.)([^-]*?)\\1([^-]*)-[^=]+=\\2\\3$";
final String string = "abc-b=ac\n"
+ "abcde-cd=abe\n"
+ "ab-a=b\n"
+ "abcde-a=bcde\n"
+ "abcde-cde=ab\n\n"
+ "abc-a=c\n"
+ "abcde-bd=ace\n"
+ "abc-cd=ab\n"
+ "abcde-a=cde\n"
+ "abc-abc=\n"
+ "abc-=abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}