package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[a-z0-9]+(?: [a-z0-9]+)*$`)
var str = `a b cde f ghijk lm n
a b cd ef g`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}