$re = '/^[a-z0-9]+(?: [a-z0-9]+)*$/im';
$str = 'a b cde f ghijk lm n
a b cd ef g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);