# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{\%\s(trans with \{.*\}|trans|transchoice)\s\%\}(.*)\{\%\s(endtrans|endtranschoice)\s\%\}"
test_str = ("{% if estimate_delivery.text is not empty %}\n"
" {% if estimate_delivery.day and estimate_delivery.month %}\n"
" <strong>{% trans %}Order delivery estimation:{% endtrans %}</strong>\n"
" {{ estimate_delivery.day }} {{ estimate_delivery.month | trans }} {{ estimate_delivery.text }} {{ estimate_delivery.interval }}\n"
" {% elseif estimate_delivery.text %}\n"
" <strong>{% trans %}Order delivery estimation:{% endtrans %}</strong>\n"
" {{ estimate_delivery.text }} {{ estimate_delivery.interval }}\n"
" {% endif %}\n"
" <div class=\"emg-clear\"></div>\n"
"{% else %}\n"
" {% trans %}No delivery estimate data available.{% endtrans %}\n"
"{% endif %}\n"
"<div id=\"sameDay\">\n"
" <input id=\"same-day-chk\" type=\"checkbox\" name=\"shipping[courier][same_day]\" value=\"1\" class=\"gui-checkbox\" {% if same_day.show == false %}disabled=\"disabled\"{% endif %}>\n"
" <label for=\"same-day-chk\" class=\"gui-label\">{% trans with {'%price%': money_format(same_day.price)} %}I want my order shipped today ( only %price%){% endtrans %}</label>\n\n"
" {% if same_day.show != false %}\n"
" <strong>{{ same_day.info.message|raw }} <a href=\"#\" data-count=\"{{ same_day.products|length }}\" id=\"sameDayDelivery\">( {{ same_day.products|length }} items )</a></strong>\n"
" <div id=\"sameDayDelivery-emgBubble\" class=\"emg-bubble\">\n"
" {% for product in same_day.products %}\n"
" <div class=\"emg-left\">\n"
" <img src=\"{{ product.image }}\" alt=\"\" />\n"
" </div>\n"
" <div class=\"emg-right\">\n"
" {{ product.name }}\n"
" </div>\n"
" <div class=\"emg-clear\"></div>\n"
" {% endfor %}\n\n"
" <div class=\"button\">\n"
" <i class=\"icon-i27-round-close\"></i>\n"
" </div>\n"
" <div class=\"emg-clear\"></div>\n"
" </div>\n"
" {% endif %}\n"
"</div>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.