package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^FWD:\[(?<pid>[0-9]{4})\] (?<prog>.+\.exe): (?<msg>.*)$`)
var str = `FWD:[1234] something else.exe: a bunch of text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}