re = /^FWD:\[(?<pid>[0-9]{4})\] (?<prog>.+\.exe): (?<msg>.*)$/m
str = 'FWD:[1234] something else.exe: a bunch of text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end