import re
regex = re.compile(r"(\/\*+ Useless CSS \*+\/)(.|[\r\n])*?END Useless CSS \*\*\*\*\/?", flags=re.MULTILINE)
test_str = ("/**** Useless CSS ****/\n"
".my-class{\n"
" margin: 12px;\n"
"}\n\n"
"/* Several Lines after including other comments **/\n\n"
"/**** END Useless CSS ****/\n\n"
".other {\n"
" padding: 12px;\n"
"}\n"
"/* Hello */")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)