using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^.:\/]+:\/\/([^.]+)(?:\.[^.]+){3}$";
string input = @"https://first.second.com
https://first.second.third.com
https://first.com
https://firstpart.secondpart.thirdpart.com
https://what.is.this.net
https://first.second.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}