// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^.:\/]+:\/\/([^.]+)(?:\.[^.]+){3}$").unwrap();
let string = "https://first.second.com
https://first.second.third.com
https://first.com
https://firstpart.secondpart.thirdpart.com
https://what.is.this.net
https://first.second.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}