package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9,\-\s]+$`)
var str = `Чтобы я мог ввести 10, 11-20, 30.
10, 11-20, 30
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}