$re = '~^[a-zA-Z0-9/.?_]+(?:-[a-zA-Z0-9/.?_]+)*$~m';
$str = 'www.google.com/flights-usa
www.google.com/flights--usa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);