re = /^[a-zA-Z0-9\/.?_]+(?:-[a-zA-Z0-9\/.?_]+)*$/m
str = 'www.google.com/flights-usa
www.google.com/flights--usa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end