import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*)\\.?\\s?([^,]+),\\s([^\\d]+)\\s?(\\d+)\\s((?:[A-Z]{3})?)\\s?((?:(?!\\d\\:\\d).)*)\\s?((?:\\d+:)?\\d+\\.\\d+)(?:\\s(\\d+))?(?:\\s((?:\\d+:)?\\d+.\\d+))?(?:\\s((?:\\d+:)?\\d+.\\d+))?(?:\\s((?:\\d+:)?\\d+.\\d+))?(?:\\s((?:\\d+:)?\\d+.\\d+))?(?:Splash Meet Manager 11, Build \\d{5} Registered to [\\w\\s]+ 2014-08-\\d+ \\d+:\\d+ - Page \\d+)?$";
final String string = "12. NUNEZ CHENG, Walter 74 Club Tennis Las Terr 3:44.57 123";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}