const regex = /(\d*)\.?\s?([^,]+),\s([^\d]+)\s?(\d+)\s((?:[A-Z]{3})?)\s?((?:(?!\d\:\d).)*)\s?((?:\d+:)?\d+\.\d+)(?:\s(\d+))?(?:\s((?:\d+:)?\d+.\d+))?(?:\s((?:\d+:)?\d+.\d+))?(?:\s((?:\d+:)?\d+.\d+))?(?:\s((?:\d+:)?\d+.\d+))?(?:Splash Meet Manager 11, Build \d{5} Registered to [\w\s]+ 2014-08-\d+ \d+:\d+ - Page \d+)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*)\\.?\\s?([^,]+),\\s([^\\d]+)\\s?(\\d+)\\s((?:[A-Z]{3})?)\\s?((?:(?!\\d\\:\\d).)*)\\s?((?:\\d+:)?\\d+\\.\\d+)(?:\\s(\\d+))?(?:\\s((?:\\d+:)?\\d+.\\d+))?(?:\\s((?:\\d+:)?\\d+.\\d+))?(?:\\s((?:\\d+:)?\\d+.\\d+))?(?:\\s((?:\\d+:)?\\d+.\\d+))?(?:Splash Meet Manager 11, Build \\d{5} Registered to [\\w\\s]+ 2014-08-\\d+ \\d+:\\d+ - Page \\d+)?$', '')
const str = `12. NUNEZ CHENG, Walter 74 Club Tennis Las Terr 3:44.57 123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}