#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^\.]+[\d]+)"
Local $sString = "LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod" & @CRLF & _
"tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam," & @CRLF & _
"quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo" & @CRLF & _
"consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse" & @CRLF & _
"cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non" & @CRLF & _
"proident, sunt in culpa qui officia deserunt mollit anim id est laborum."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")