import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\.]+[\\d]+)";
final String string = "LOREM : 10505050\n"
+ "IPSUM : 1050051051084\n"
+ "DOLOR : 2620620620652\n"
+ "AMETI : 54084840540540\n"
+ "LOREM : 10505050\n"
+ "IPSUM : 1050051051084\n"
+ "DOLOR : 2620620620652\n"
+ "AMETI : 54084840540540\n"
+ "LOREM : 10505050\n"
+ "IPSUM : 1050051051084\n"
+ "DOLOR : 2620620620652\n"
+ "AMETI : 54084840540540\n"
+ "Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod\n"
+ "tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam,\n"
+ "quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo\n"
+ "consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse\n"
+ "cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non\n"
+ "proident, sunt in culpa qui officia deserunt mollit anim id est laborum.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}