import re
regex = re.compile(r"([\w\s]+): ([\w ]+)(?:- ?([\w -]+))?")
test_str = ("Asia: Asian Cup - Play Offs\n"
"Asia: Asian Cup\n"
"Asia: World Cup - Qualification - First Stage\n"
"Australia: A-League\n"
"Belgium: Jupiler League - Championship Group")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")