re = /([\w\s]+): ([\w ]+)(?:- ?([\w -]+))?/
str = 'Asia: Asian Cup - Play Offs
Asia: Asian Cup
Asia: World Cup - Qualification - First Stage
Australia: A-League
Belgium: Jupiler League - Championship Group'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end