const regex = /^[^-]{8}-[^-]{3}-[^-]{3}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^-]{8}-[^-]{3}-[^-]{3}$', '')
const str = `dbcdefgh-333-333
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}