$re = '/^[^-]{8}-[^-]{3}-[^-]{3}$/';
$str = 'dbcdefgh-333-333
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);