import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[0-9],[1-9][0-9]+|0,[1-9]|1,[2-9]|2,[3-9]|3,[4-9]|4,[5-9]|5,[6-9]|6,[7-9]|7,[8-9]|8,9)\\b";
final String string = "7,10\n"
+ "5,3\n"
+ "0,1\n"
+ "8,9\n"
+ "0,20\n"
+ "10,20\n"
+ "21,12\n"
+ "1,12";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}