package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<title>.+)\s*~\s*(?<a>.+)`)
var str = `th the ~ a1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}