const regex = /(?<title>.+)\s*~\s*(?<a>.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<title>.+)\\s*~\\s*(?<a>.+)', '')
const str = `th the ~ a1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}