package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([^.]+).SH|([^.]+).SS|([^.]+).SSd|(.*))$`)
var str = `cgrbat.SS
CGRANT.SSd
BADGER.SH
BADGEF.XK
XC.SH
XX.SSd
KS.PO
LSOSUF.OI
KLSWWAAS.SSH
SAFA.SS
DSAFW.SDD
OAFSFS.SSd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}