$re = '/^(?:([^.]+).SH|([^.]+).SS|([^.]+).SSd|(.*))$/m';
$str = 'cgrbat.SS
CGRANT.SSd
BADGER.SH
BADGEF.XK
XC.SH
XX.SSd
KS.PO
LSOSUF.OI
KLSWWAAS.SSH
SAFA.SS
DSAFW.SDD
OAFSFS.SSd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);