$re = '/(?:[0-9]+|twitter|consectetur)(?![0-9a-z]*\[\/[a-z]+\])/mix';
$str = '123456 Lorem ipsum [tel]123456[/tel] dolor sit [tw]@twitter[/tw] amet, consectetur adipiscing elit [a]example[/a]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);